Can't set the domain


#1

Ok. It’s all done here.
The tudosobren.tk is already pointing to the 000webhost servers, tudosobren.cf too, and i can’t set BOTH as my domain.

The domain tudosobren.cf CNAME must be pointing to tudo-sobre-n.000webhostapp.com

Can someone help me?


#2

I am not a DNS expert but I think you can set a CNAME record to point your other DNS to the DNS already pointing to your 000webhost website.
This can be done in your registrar DNS magagement for your tudosobren.cf domain.


#3

i registered the second one because the first wasn’t working


#4

Can someone help me please?


#5

@gabr_guedes

Actual nameservers for 000webhost are:-

ns01.000webhost.com
ns02.000webhost.com

You want to do it using nameservers or by adding cname?


#6

CNAME. So, why isn’t it working?


#7

may be you have added both wrong name servers and cname…

just remove the existing wrong name servers record…and also the existing both(with and without www) cname records…

after that now add again the cname “tudo-sobre-n.000webhostapp.com

and then try after some time(wait till its get fully propagated)


#8

dont point the domain , park it . it worked for me


#9

I have the same issue, domain pointing through CNAME settings is bugged right now (see Pointing CNAME isn’t working). The workaround is not applicable in may case (can’t change the DNS associated with my domain).

Would appreciate an update from 000webhost on this.


#10

@nicjac what is domain and conical names?


#11

Domain is http://www.design-principle.co.uk/ , name on 000webhost is design-principle-test


#12

@nicjac Now I guess…why domain din’t worked may be because of the wrong “A” record with value “216.21.224.199” which does’t belong to 000webhost.

i suggest…just park your domain using nameservers.

For this remove all highlighted records in the image from your domain dns pannel…

and add new 000webhost name servers:-
ns01.000webhost.com
ns02.000webhost.com

Or

If you want to point using cname,
then add the cname record again instead of name servers.

this should work(but do wait till the records get full propagated)


#13

not working.
tudosobren.tk still showing the 000webhost’s “There’s nothing here, yet.” error and I can’t point it to my website.


#14

@gabr_guedes if you pointing towards 000webhost using cname…then remove the wrong updated nameservers.

Instead of cname(pointing)…use nameservers(park) which is recommended

ns01.000webhost.com
ns02.000webhost.com


#15

Ok, but if I park it, it will only change the first page, not?
Like… the first page will be at “tudosobren.tk” and everything else will still show the domain "tudo-sobre-n.000webhostapp.com?


#16

No, if you park your site will use the url “tudosobren.tk”.
Also, to make sure the subdomain “tudo-sobre-n.000webhostapp.com” contents are not visible you can tickle a little bit your .htaccess file to rewrite the URL so every time someone requests the subdomain at 000webhost it will get redirected to your real domain.
Take a look at my site installed 2 days ago hhocarfuelcell.com . It’s made the same way (parking and htaccess redirecting).


#17

Yes as ocuric said… you can use the below code to redirect to your domain name “tudosobren.tk”

Paste this in .htaccess file:-

RewriteEngine on
RewriteOptions inherit

RewriteCond %{HTTP_HOST} ^tudo-sobre-n.000webhostapp.com$ [NC]
RewriteRule ^(.*)$ http://www.tudosobren.tk$1 [R=301,L]


#18

@Infinity check this out:

(Sub)domain Type Target
mywebsite.nl A 11.22.33.444
*.mywebsite.nl CNAME mywebsite.nl
myproduct.nl CNAME mywebsite.nl
mywebsite.be CNAME mywebsite.nl

DNS server resolves the domain names

Assuming you have the subdomain provider.mywebsite.nl which points to networking4all.com

When a visitor goes to provider.mywebsite.nl, the DNS server will find the CNAME-record networking4all.com. 
The DNS server will look up the new name networking4all.com
The A-record for networking4all.com provides the corresponding IP-asdress.
The visitor arrives at networking4all.com

Limitations:

The extra lookup for the CNAME > New Name > IP-address, delays the process with a few extra milliseconds 
> You can not create a CNAME-record for the main domain name (mywebsite.nl) itself, this must be an A-record 
MX- or NS-records may never point to a CNAME record.

I found this info by mistake on https://www.networking4all.com/en/support/domain+names/dns/cname-records/
I am not a DNS expert but seems that before we can cname the WWW or other subdomain we should first create the A-record to point the domain towards the propper IP address.
I hope this helps all our issues of pointing the domain.


#19

@akhilkumar332 apologies for not responding earlier. I got BT to modify the domain’s records. It is still not working! The CNAME record was set properly (see below for a screenshot from mxtoolbox).

Any help?

Thanks.

Nicolas


#20

The issue is determining IP to point to my IP has changed a few times since I’ve checked it via mysite.000webhostapp.com :confused: