FTP error: "421 I can't accept more than 5 connections as the same user"


When I try to upload files, download files, and sometimes even connect to the ftp server, I get the following error: “421 I can’t accept more than 5 connections as the same user”

Can't upload files to my free webhost ftp

Hi @wings!

As the error states, this usually means you attempted to connect to FTP more times than allowed at once. This depends on FTP client and how it handles the connections.

Please try again later. If the problem persists please go to 000webhost cPanel > Settings > General > FTP > Off > 1 min waiting > On again and retry.


Are you using FileZilla?



Yes, I’m using filezilla. That probably solves it. If the error doesn’t happen again, I’ll mark the ticket as solved.

But for now, it is quite impossible to tell, because I’m having a different problem:

If this is solved I’ll know if the problem of the concurrent users was solved.


Try edit and network configuration…


Still not working.
The network configuration wizard test ended like this:

Failed to create listen socket on port 0, aborting.
Connection closed

I did this, selected “Get ip from external address”, as you mentioned in other topic.


For FileZilla to work correctly you need to keep running the wizard until everything checks out fine.


Good response:

Bad response:


Connecting to probe.filezilla-project.org
Connection established, waiting for welcome message.
Response: 220 FZ router and firewall tester ready
USER FileZilla
Response: 331 Give any password.
PASS 3.27.1
Response: 230 logged on.
Checking for correct external IP address
Retrieving external IP address from http://ip.filezilla-project.org/ip.php
Checking for correct external IP address
IP 1xx.1xx.7x.5x bhj-bcg-hj-fj
Response: 200 OK
PREP 6191
Response: 200 Using port 6191, data token 1612299333
PORT 179,126,79,59,24,47
Response: 502 Port mismatch. Received arguments contained port 50000. Command has been tained by router or firewall.
PORT command tainted by router or firewall.
Connection closed


Disable your firewall and antivirus protection shields on your PC, run the test, if it succeeds, find out how to allow FileZilla as exception on your software.
If that doesn’t work try your router settings, or or etc, login, disable firewall, run test and try again.
If that doesn’t work contact https://www.algartelecom.com.br/ and ask them to provide instructions to disable firewall and allow FTP to work without issue.