DNS and Nameserver question


Check this tutorial and let me know how it went for you

You can use database option if you are unable to reach your site.


Ok so heres what I have


My question is should i make the http:// or https:// here.

Also when browsing to my website if you use http://danowens.me it produces this:

which is kind of my webpage… the picture although constrained to 300x300px is obviously oblong (oval)

So using http:// thats what you get.

When you use https://
ie. https://danowens.me

this is what you get:

As per your suggestion I set up everything on godaddy, 000webhostapp, and cloudflare the way they were in the pictures. Meaning my site should be on https:// correct? does that then mean i need to change in wordpress from http:// to https:// and all is fixed, or did I royally f something up.

I’d be willing to pm you the logins to my accounts if that makes it easier for you. I have a job interview on wednesday I was hoping to have this for. I was finished building the actual site last night and was happy to have it done early. rofl. I think I’m possibly overthinking this way too much.

Thanks for your patience and help. It is greatly appreciated.


I’ll look into this soon I’m swamped currently.


No worries I think I have it figured out. I scoured the interwebs for hours to find several solutions which seem to have worked.

First off if your run cloudflare with wordpress, it’s imperative to download the plugin called “Cloudflare Flexible SSL”

I recommend setting up cloudflare and getting the certificate before messing with the addon.
After the addon is installed I had to go into cloudflare and go to crypto and turn it to always https://

After I used that all my pages started working as Secure, however my css and other scripts couldn’t load because they were being pulled in through http:// so there were a ton of mixed content warnings.

I don’t know if its the way that wordpress gets installed on webhost’s end or something else but the whole backend was in http:// instead of https:// originally. So the wordpress dash wouldn’t work at all.

Now with everything secure I could at least enter the backend. The frontend stuff wasn’t working properly it was pretty janky but I could get into the backend.

So at this point I downloaded the addon “better search replace” and searched for every instance of http://dan0.webhostapp.com/ and replaced it with https://danowens.me
http://danowens.me/ replaced by https://danowens.me
https://dan0.000webhostapp.com replaced by https://danowens.me
http://www.danowens.me replaced by https://danowens.me

There were a few other linkes i seached and replaced, everytime replacing with https://danowens.me

At this point 90% of everything worked flawlessly. I had to readjust some of the sizes of my pictures because for some reason the size constraints I had entered weren’t working. So I just resized the picture to the constrained size and called it a day.

I did go to freenom and cloudflare and played for a few hours setting up wordpress onto an already forwarded domain. I tried parking my freenom domain and linking just the nameservers, but once you install wordpress it immediately gives you “security errors”. I also tried pointing freenom and using cloudflare, then installing wordpress. Same issues with the non secure websites and the dash not working.

There has to be something with the automated installation of wordpress.

If you install wordpress with cloudflare on then go to general settings and change wordpress url and site address url to be https:// instead of http:// it immediately gives you too many redirects and you can’t even connect to the backend or frontend. You have to go in via the ftp and add come code to either your functions.php to manually set the siteurl and wordpressurl.

This is when I found “Cloudflare Flexible SSL” and my whole process started. After confirming it worked on the new site, I applied (everything above) the same fix to my portfolio site. And wallah.

Anyway hopefully someone might find this useful.

I still think there’s a problem with installation of wordpress onto a domain not 000webhostapp.com. I don’t know if you make it so when you’re choosing the url during the first step of installing wordpress if you can somehow have it push the https:// to the install directory but i think that’s what needs to happen. If you install wordpress onto 000webhostapp.com with no forwarded domains and login to the backend you notice its https:// secure and everything is gravy. Once dns becomes involved, changing the url or installing wordpress always puts the whole wordpress into http://

So let me clarify, for instance lets say I bought danowens.me point it to cloudflare and in turn point cloudflare to 000webhost. Lets say everything is working as it should, you have your certificate, when you type in the address it forwards you where you want. Now lets say you install wordpress. It will let you pick danowens.me as the URL during the installation, which sets up your siteaddress url and wordpress url to danowens.me now. However it doesn’t set it to https:// it sets it to http://

Now lets say you install wordpress on a fresh 000webhost.com site. No DNS or anything set up, just plain ol’ 000webhost.com. Meaning your siteaddress url and wordpress url will be something like yoursite.000webhostapp.com. However this installation ALWAYS stays in https:// and everything works great.
However whenever your add DNS if you don’t have SSL your site is going to be broken.

At least this was the case for me in this whole situation. If you could somehow choose SSL when installing wordpress onto a non 000webhost domain then that might solve it. I’m not familiar with how any of that stuff works though, so this is only my best guess at a solution.