Http 500 error. Please help


#24

Did it mean that i need to generate a new key?


#25

Can you generate a new key?


#26

Solved!
( I think )

http://june30test.000webhostapp.com

Alright boom!

I opened database.php from config and inserted

‘options’ => [PDO::ATTR_EMULATE_PREPARES => true, PDO::MYSQL_ATTR_COMPRESS => true,]


#27

Amazing!!! I will insert the line and try to run again.
Where do you get the code?


#28

https://laracasts.com/discuss/channels/laravel/whoops-looks-like-something-went-wrong-12


#29

putenv is disabled on 000webhost so is causing issues with env file


#30

Hi @Infinity
Now the error is this

I checked the password, username, and db name. It should be okay but no… what would another option you’d suggest to fix this error?


#31

Insert this after your database info

‘options’ => [PDO::ATTR_EMULATE_PREPARES => true, PDO::MYSQL_ATTR_COMPRESS => true,]

Just after


#32

Hi, how to fix this,

I checked the db and user name in .env, no spaces in between the required name. everything should be ok. but this error, how to fix


Deploy Laravel Project into 000webhost site
#33

Hi all!

Everything appears to load fine now… :slight_smile: Could you please confirm?


#34

like this? did this, the problem is the same


#35

You had to change forge to your actual values, I have done it for you.


#36

Amazing! Thank you so much @Infinity. Appreciate a lot!


#37