My site get redirect to 000 domain


#1

i have a domain and when i enter the domain in URL line i get redirect to 000webhost given domain, yet pages in the website stay in the bought domain.

look at my website
spinnersisrael.xyz - this gets redirect
http://spinnersisrael.xyz/contact-us - stays normal

i use WordPress 4.7.3 if that important


#2

Check this tutorial and let me know how it went for you


#3

did it , now my site doesnt comeup at all,not the parkked domain and not the subdomain and not the 000webhost given domain…

edit seems to be that pages in the web do come up like http://spinnersisrael.xyz/contact-us/ yet the main page doesnt comeup at all


#4

Can you confirm that within the WordPress settings you’ve used “http://spinnersisrael.xyz” as the WordPress & Site URL?


#5

here is an image showing that indeed the settings are correct(i think).
yet am unable to access any of the pages though any of the domains now


#6

Both are loading fine still.

Can you screenshot this screen below

Else can you visit public_html and rename the .htaccess file to .oldhtaccess


#7

i cant access my website and wordpress at all still get HTTP ERROR 500 , i renamed the file, noting changed yet


#8

Could you try 000webhost.com > general settings > php version > 5.6


#9

changed yet nothing…

turned on errors and i found

Fatal error: Call to undefined function get_bloginfo() in /storage/h5/939/1032939/public_html/wp-includes/class-wp-locale.php on line 233

thats the code at 233

		if ( 'rtl' === $this->text_direction && strpos( get_bloginfo( 'version' ), '-src' ) ) {
			$this->text_direction = 'ltr';
			add_action( 'all_admin_notices', array( $this, 'rtl_src_admin_notice' ) );
		}

what now?

edit when back on 7.1 i get

Fatal error: Uncaught Error: Call to undefined function get_bloginfo() in /storage/h5/939/1032939/public_html/wp-includes/class-wp-locale.php:233 Stack trace: #0 /storage/h5/939/1032939/public_html/wp-includes/class-wp-locale.php(113): WP_Locale->init() #1 /storage/h5/939/1032939/public_html/wp-includes/load.php(925): WP_Locale->__construct() #2 /storage/h5/939/1032939/public_html/wp-includes/wp-db.php(1575): wp_load_translations_early() #3 /storage/h5/939/1032939/public_html/wp-includes/wp-db.php(658): wpdb->db_connect() #4 /storage/h5/939/1032939/public_html/wp-includes/load.php(404): wpdb->__construct('id1032939_wp_0e...', 'bd541eb126fac38...', 'id1032939_wp_0e...', 'localhost') #5 /storage/h5/939/1032939/public_html/wp-settings.php(107): require_wp_db() #6 /storage/h5/939/1032939/public_html/wp-config.php(77): require_once('/storage/h5/939...') #7 /storage/h5/939/1032939/public_html/wp-load.php(37): require_once('/storage/h5/939...') #8 /storage/h5/939/1032939/public_html/wp-blog-header.php(13): require_once('/storage in /storage/h5/939/1032939/public_html/wp-includes/class-wp-locale.php on line 233

#10

If you hit my name then message and send your 000webhost.com details I’ll take a look if you want.


#11

This issue was fixed as far as I am aware; do post back if still experiencing issues.

Issue was from a plugin using the wrong URL and causing issues.

Changed to