SMTP configuration help please?


#1

I’ve been unable to properly configure my site to use 000webhost’s SMTP server. I am developing a website which would send an activation code to an email address after a user registers for an account.

I am using Kohana v2.3.4 and their Swift mail helper. I used mx.000webhost.com as the hostname, port 25, the username and password which I won’t be disclosing. :rolleyes:

With these settings, I get this error:
There was a problem reading line 1 of an SMTP response. The response so far was:<br />[]. It appears the connection has died without saying goodbye to us! Too many emails in one go perhaps? (fsockopen: #0)

When I telnet mx.000webhost.com it says:
error 10060

I tried changing it to server28.000webhost.com but the result was the same.

I changed it to ns1.000webhost.com and the error says:
Authentication failed using username ‘**’ and password '

Ok, you get the idea. Can anyone help me in using the correct settings?


#2

Please setup your mail to use google apps. This will make life easier for everyone. 000webhost does not provide a dedicated smtp server. You can try using your domain as the smtp outgoing server, but it may or may not work. I’m not really sure if you can even do that. Your best bet is to use google’s smtp server through google apps.


#3

Thanks for the info.

Ok. I do have a Google App Engine account if that’s what you mean. Do I have to do anything in the cPanel or not? Do I only need to use their hostname and the username and password that I use to login to Google?

Sorry for so many questions. I’m really new to web hosting… :slight_smile:


#4

ok so i did use google instead and i got it working in my local web server… the emails were being sent properly but when i uploaded my site here, it didn’t work… here are my email configuration settings:

$config[‘driver’] = ‘smtp’;
$config[‘options’] = array(
“hostname” => “smtp.gmail.com”,
“port” => “465”,
“username” => “",
“password” => "
*”,
“encryption” => “tls”
);

i tried using the default port which is 25 and removed encryption=>tls but still it didn’t work… help anyone?


#5

go here and follow the instructions: https://www.google.com/a/cpanel/domain/new
If you can’t figure something out I/we’ll be glad to help.


#6

thanks sir… i got stuck in this step: http://i290.photobucket.com/albums/ll276/dokgu11/image.png

000webhost says that that feature is only available if i host my own domain…


Errors With Code
#7

You can only set one MX record in your 000webhost control panel. If you host your own domain you need to configure those records in your domain control panel of your domain registrar.


#8

I’m sorry I wasn’t able to follow. If I can set one MX record in cPanel, how come when I click on Modify MX Record, it says the feature is only available if I host my own domain.

Could you provide a step-by-step procedure sir?


#9

My bad, i confused something. MX records are only changeable when hosting your own domain.


#10

Ok, thanks for the help anyway.

Is there a work-around for this issue? I could just use my gmail account… I created one dedicated just for the site so it’s not a problem actually. It was working in my local Apache, it just failed after uploading the site.


#11

I’m not sure if that would work or not, but it wouldn’t hurt to try. The servers here only support SSL if you are on a server that has already been moved (check the announcements to see if yours has been moved). Gmail forces ssl/secure connections now. Anyway good luck with your site.


#12

Hello, im trying to send mail with phpmailer through gmail.

Is SSL connection supported by free 000webhost?

ssl://smtp.gmail.com

Server Name server28.000webhost.com
IP Address 31.170.160.92
Apache ver. 2.2.13 (Unix)
PHP version 5.2.*
MySQL ver. 5.0.81-community
Activated On 2011-06-01 06:16
Status Active