Application Error appears when going onto site

Hi I’m trying to get into my website but when I try I get the error:

Application error

An error occurred in the website and your page could not be displayed. If you are the website owner, check your logs for details.

Can someone help me please? I can’t even get into file manager as I get the error:

This site can’t provide a secure connection uses an unsupported protocol.


my website is

Application error can be resolved

The bottom error is more concerned towards your local PC / network there isn’t much we can do to resolve that for you.

Try using different browser / proxy / VPN / ensuring date - time is correct or try another connection / another device.

okay thanks, but would you be able to see what’s wrong with my site?

We only help with hosting issues, your issue is related to bad coding or a bad script.
Contact your script author, your developer or upgrade to Hostinger for live chat assistance.

okay well i managed to get onto filemanager on my phone, my .htcaccess file was empty for some reason so put the code back in there and I’m still getting application error. I added:

php_value display_errors 1 as well but nothing shows.

Can I please get help? That was the only file altered that caused this and now it’s back to normal it’s still giving me an error so i just don’t know what to do

Deleted the .htaccess file and created a new one with the error debug code inside.

Seems your site now loads, that would mean the directives in .htaccess are bad or unsupported on free plan.

1 Like

And what’s the deal with the not within the allowed paths error now? I never had that earlier

Thank you! also don’t if you’ll be able to help with this my public_html folder for my other website: has just completely disappeared now


Seems you’ve deleted “public_html” directory which caused this issues.
Anyways i’ve fixed it for you.

Thanks for your help.

After my I am now getting this error on the site:

Warning: file_exists(): open_basedir restriction in effect. File(…/…/classes/class.user.php) is not within the allowed path(s): (/opt/awex-pages:/storage/ssd2/917/12179917) in /storage/ssd2/917/12179917/public_html/includes/config.php on line 38

Warning: file_exists(): open_basedir restriction in effect. File(…/…/…/classes/class.user.php) is not within the allowed path(s): (/opt/awex-pages:/storage/ssd2/917/12179917) in /storage/ssd2/917/12179917/public_html/includes/config.php on line 42

The code it’s referring to is:

//load classes as needed
spl_autoload_register(function ($class) {

$class = strtolower($class);

//if call from within assets adjust the path

$classpath = ‘classes/class.’.$class . ‘.php’;
if ( file_exists($classpath)) {
require_once $classpath;

//if call from within admin adjust the path

$classpath = ‘…/classes/class.’.$class . ‘.php’;
if ( file_exists($classpath)) {
require_once $classpath;

//if call from within admin adjust the path

$classpath = ‘…/…/classes/class.’.$class . ‘.php’;
if ( file_exists($classpath)) {
require_once $classpath;
$classpath = ‘…/…/…/classes/class.’.$class . ‘.php’;
if ( file_exists($classpath)) {
require_once $classpath;


So what happens is that if a folder is a few directories away it’ll call that code, how can I get around this error? I was not having an issue with this before the .htaccess file needed to be reset

I’ve fixed it for you. :slight_smile: As you can observe in above quoted code, that $classpath was trying to access file outside of “public_html” which was generating open_basedir restriction error. Simple solution was to remove addtional ../../ which fixed the issue.

This is necessary for files in my admin folder, without those extra ones the files will not load.
The admin index page is in users/admin so the extra ones was so the file is able to call it if that makes sense?

Sorry but you can’t access files outside of public_html.
Whatever the path you set for defined variable should be inside public_html then only it will work.

I’m not trying access files outside public html though.

Like I was saying with my example that code is only used when a file needs to go back that amount in order access that file.
This was working yesterday so surely there’s something that can be done?

Try to recheck your scripts or restore if you’ve any local backups.

Now seems to back working. If you did something thank you!

And thank you for your help in getting this all sorted for me :slight_smile:

1 Like

Could it be possible that there’s still something wrong with my htaccess file?

Becuase I’ve noticed that unless I have

php_value display_errors 1 I will get the application error again. I don’t have this in my other website and it works fine

@lross Is your problem solved now?

Yes, everything seems to be working now :slight_smile:

Thank you!

1 Like