Denied access to web resources


These are the errors i see on my website, for some reason, instead of sending requests to “…resource” it sends requests to ""

This is how my domains area look, what I would really want to do is just have the as the main and only domain but I cannot find any option to make this true. I am using wordpress and in my wordpress settings the home and site url is
*Since i can only put one image here is the image link for the domain area in my control panel:
I don’t know what’s going on and why the requests are sent to the wrong address. What am I doing wrong?

Wrong urls in wordpress website

There is no way to make it primary because it is a pointed site. The requests are always sent to the 000webhostapp URL and then forwarded back to the domain. Are you just seeing those errors when you look at the console? If so you should just ignore them if the site is working properly.


But the site does not work properly. The access to these resources are blocked. And still for some unknown reason all the urls in my website start with devshift.000webhost instead of despite the fact that in the wp_options table i changed all urls to


Hi bodokh!

For the begin, please change the PHP version to a lower one: cPanel > Settings > General > Change PHP version > 5.6.

Then try changing the URL again from WP Admin Panel > Settings > General.


Check this tutorial and let me know how it went for you


Your website is loaded via HTTPS and your resources may be on http. also JS should be loaded from the same domain name.


All the steps in the tutorial you sent me was exactly what I have already done, the result remains the same, 000webhost is the only hosting server where this problem occurred, in every other service I tried this did not happen.


@bodokh I have fixed this issue by adding Access-Control-Allow-Origin header to your .htaccess.

Those errors are now gone, and your files should be loading normally :wink: