Having lots of problems with my website


So I have a website hosted here, but instead I have my domain “tugapop.xyz” showing.

  • When I load the site, the thubnails that have been showing before, don’t appear now.
  • When I click on a post, it says that tugapop.xyz certificate is invalid
  • When I share a post to social media, it doesn’t fetch the content of the article

That’s it for now, if someone could help I would appreciate


@tugapop You need to use only “http”.

Else use “Cloudflare” for SSL(http), which solved your issue instantly.


The nameserverrs need to be changed at my xyz domain registar right?
Also I shared a http link on facebook, and the thumbnails still don’t show.

How can I fix that?


Yes you need to change to cloudflare nameservers. :slight_smile:


What about the social media thing?


Can you explain your issue??If possible with screenshot.


When I share on Facebook, it doesn’t appear thumbnails, title and description

I’ve tried debugging too.



@tugapop Try to post using “https”.

Also as suggested above use Cloudflare.


Yes, I’ve tried that too. Doesn’t work either.


I see still your domain doesn’t loads over “https”,
First link it with cloudflare and then try again.