Is it because of the updating or something's wrong with my site?


I just got this error whenever I try to open ANY topic on my site:

Database Error
Unknown column ‘mem.is_approved’ in 'field list’
File: /storage/ssd4/706/1889706/public_html/Sources/Display.php
Line: 600

Now I’ve read the message at the top but still am scared so am asking. Is something totally wrong with my site (I didn’t touch it since yesterday, when it worked fine) or it’ll be fixed by itself tomorrow or in a few days?


Thanks for reading before posting. There has been one other user with a MySQL problem today so try waiting a little while.


Still the same, a new user registered but nobody can open any topic at all because of the above error.


What forum software are you running? Try checking your config file to make sure the database details are correct, and check the error logs if there are any, then report back the entire content of said error log (provided there is one).


All details are correct after double checking. I’m on SMF 2.0.13 and after trying to open any topic it gives this “amazing” error log:

Today at 06:36:09 PM
Apply Filter: Only show the error messages of this session 6f3a95767798a723cf3a25d16f7065b9
Apply Filter: Only show the errors of this type Type of error: Database

Really informative… but yeah, I didn’t do anything and it just broke itself yesterday :frowning:


Hi @MegasXLR!

You receive this error because the table smf_calendar inside your database is empty. If I may say, this appears to be a corrupted SMF website.

I suggest you to reset your website (000webhost cPanel > Settings > General > Reset website) and reinstall SMF under PHP 5.6 version.


I changed php version a few times up and down to see which is the highest that 2.0.13 can run on, no idea if that had an impact. Alright, today I’ll reinstall the site for the Nth time xd I don’t mind that but i can’t be sure that it won’t suddenly break again when I’ve got more topics and users. Otherwise reinstalling is no problem.


Please reinstall SMF under PHP 5.6 and reply the results.


Reinstalled everything. Now sometimes when I want to install a package it gives this error:

Database Error
You have an error in your SQL syntax; check the manual that corresponds to your MariaDB server version for the right syntax to use near 'FROM smf_log_packages
WHERE package_id = ‘KCToker:MibbitIRC’
AND install_st’ at line 2
File: /storage/ssd4/706/1889706/public_html/Sources/Packages.php
Line: 248

But after spamming the “Install” button a few times it gets installed and works perfectly.


The selected package is probably not compatible with the MySQL/PHP version.

Lower the PHP version to 5.3 - 5.4 and try again.


Tried all php versions between 5.2 and 5.6. I need to click “Install” between 1 and 20 times depending on the site’s mood… I managed to install the mods though. Let’s see how long it will take to get bugged again like it did 2 days ago for no reason.


Either it is related to the MySQL problems we have (please read this topic for more information), either some parts of SMF are not compatible with 000webhost.


Sure hope it’s the second thing. Thanks a lot for your help man. And sorry if I sound a bit mad but I just lost hope of creating a working website since I had to reinstall it a lot of times because of problems heh.


No problem. We’re here to help each other :wink:

You can try installing other forums, such as MyBB if thing don’t go well…


Just installed SMF 2.0.11 and am currently using php version 5.3. I did have a few errors while installing some mods but they were way less than before. Now I posted a few topics and there’s no problems. Hope it just works from now on :grinning:. Here it is btw: