My website does not show the index.html page as it's frontpage

Hello, I have added a index.html page on my website’s file manager (in the public_html folder). When an index.html file is added to the public_html folder, it’s supposed to show as the front page of the website. But this is not happening - currently it’s accessible by adding /index.html to the url, which I don’t want. I want that file to be the homepage.

How do I make the index.html file my website’s front page (accessible by going to website’s original URL,

Please guide… Thanks! :slight_smile:

Delete any other file in public folder called index.php or index.html first then upload your new index.html

If you aren’t going to be using WordPress it would be worth removing it by using general settings on our panel and the reset option.
Then freshly upload your website to the public folder.

1 Like

Thanks @Infinity! I found a file named index.php in public_html - after deleting it, I got my desired result. Thanks a lot again! :slight_smile:

Glad to hear :grin: happy site building :blush: