Reset website, no longer working


#1

So I was having an issue, which has turned into two issues. My website was not loading images properly. When I reset the website to try and fix the issue, the site isn’t coming up anymore. I readded my files through filze zilla, and still not working. Any suggestions


#2

Hi @dankhayutin!

You had to place your website content in /public_html. I have corrected the issue for you :slight_smile:


Please link the mixed content (css/js) using https:// protocol.


#3

Thanks so much for the helo @teodor

In terms of linking the css and js, is there a particular way to do this? Cheers


#4

Use https:// as protocol. Or better, use // instead of protocol. (// instructs browser to load the content from the same protocol your website is currently accessed). Do this to prevent the blockage of mixed content in case of security reasons.

Example:

replace:

<script src="http://code.jquery.com/jquery-3.3.1.min.js"></script>

with:

<script src="//code.jquery.com/jquery-3.3.1.min.js"></script>

#5

so once i make those adjustment in my indext.html, the site should work again? @teodor


#6

I followed the instructions but the site still isnt working.

So when i first put my site up, everything worked, however the images for my portfolio were missing. I then tried to reset the site and followed the same steps but now it says that the website is no longer available. So a smaller issue definitely turned into a bit of a bigger one. Any other suggestions on how to fix both issues would be great.


#7

Local computer issue maybe?


#8

Renders fine here.


#9


#10

Try simply loading your site https://danielkhayutin.000webhostapp.com/

Then pressing F5 + CTRL at the same time a few times?


#11

ohhh @teodor it defaulted back to the original default name given to me. I had it set up so it was just danielkhayutin.ca

Is it still possible for me to set up so im using my own domain?


#12

Looks fine here?
http://danielkhayutin.ca

I usually just use 000webhostapp for easiness.


#13

Your site is loading fine now, and no errors appear to occur :slight_smile:


#14

thanks so much the help. Side note, is there any reason why some features may work for desk top and not mobile? For example, icon tabs load on desktop, but not on my phone. Also, images for portfolio load on safari, but not on chrome

Does this have something to do with how my code is structured?


#15

I am sorry for late reply.

If you’re using a library such as Bootstrap, Materializecss, etc, these ones have automatic resizing features for different screens.

Check and make sure you’re setting up all DIV tables/columns to support lower screen resolutions.

Also, images for portfolio load on safari, but not on chrome

Your images are loading fine on my Chrome browser. Please clear your browser cache and retry.