CNAME on Cloudflare not working. Error: There's nothing here, yet


I have looked through the forum, found people have the same issue, but no resolution fond, so here goes:

  • My domain uses Cloudflare DNS.
  • CNAME points to my-hosting, as given by tutorial. The whole world, except for Pakistan and 000webhost sees this, the DNS records have propagated by now. (see screenshot).
  • There is a grey cloud in Cloudflare, as it should.
  • The page dipslayed under my domain says: There’s nothing here, yet. This domain is ready to be registered.
  • The pages under my-hosting .000webhostapp .com work normally.
  • 000webhostapp .com Page setup says it is waiting for nameservers.
  • There is no A record, on the domain, but does there need to be one?
    Anyway, it does not work. I have followed the tutorial and forum, nothing helps.Screenshots below. (Since this forum allows only one image in post for new users (real smart), I had to put three screenshots in one picture.


HI @AKH5269
Welcome to our forum!

Add a cname record as following.

Name - @ (This will be chage to your domain name)
Value -

If you have parked your domain at 000webhost, remove it and point it here.

If you have any issue post here or PM me.


thanks for the help. I did as recommended, it did not work though.

  • I now have 2x CNAME record (www and @), both pointing to 000webhost site, using Cloudflare DNS (which automatically changed @ to domain name)
  • I still get “Nothing here yet” for both www and non-www versions of the site.
  • I still get “Waiting for nameservers” under My domains.

I include a screenshot of the Cloudflare DNS setup and 2 shots of G Suite Toolbox Dig, for www and @ CNAMEs. Thay are different. Could this have something to do with the “Flattening”?


Hi @AKH5269

PM me your domain, if you can.


Switched to PM and fixed the problem.



My domain uses Cloudflare DNS. There, a CNAME record points to xyz.000webhost .com as it should I have checked the DNS propagation - it is all set up. But the 000webhost My Domain management page says, the Linked Domain is still “Waiting for namerservers”. Recheck button does not change that. What is wrong?


Hey you have to add two came records as one you have added above and add one more as @ and your website address. Then try checking again


You need to select the other option if you see “waiting for nameservers” as you aren’t pointing to and you appear to be using the CNAME method instead.


Problem fixed in PM and CNAME on Cloudflare not working. Error: There's nothing here, yet