Nameservers aren't changing


Hello, it’s me again!

It’s coming up to 24 hours since I have changed the name servers on my website to and but it seems that the domain has been whitelisted on 00webhost but it isn’t detecting the new name servers. Please reply back if you know why. Thank you!


Hi @Renderman! doesn’t appear to have it’s Name Servers changed to 000webhost’s ones.

Please go to your registrar cPanel, at DNS section and make sure you are using these NSs:



After doing so, please go to 000webhost cPanel > Set web address > Add domain > Park domain > and wait for Name Servers :slight_smile:


The name servers on are NS01.000WEBHOST.COM and NS02.000WEBHOST.TK. I have also confirmed and checked this. Do you think the problem may be that the domain hasn’t been fully white-listed on 000webhost? Thanks



It should be .COM, not .TK.


@Renderman if that’s still not working, you can give a try to Cloudflare.
Here’s a link to the tutorial.
And, if you need help in a step from the tutorial, don’t hesitate to ask us!


@renderman, was the issue solved for you after changing the nameservers to what @NGiNX suggested?


The domain works with Cloudflare but I need somewhere to host my files for the website I made in HTML


Nope. The domain still doesn’t work here.


I have used a .tk tld before and it worked fine. I also tried deleting the domain and re getting it then putting the ns’ in but that still didn’t help.


Host them on 000webhost!


You have to point the domain to your 000webhost website, in order to use cloudflare.
To point your domain, follow this tutorial:

Instead of adding CNAME to freenom, add them to cloudflare


Now that the domain is on Cloudflare, you just need to follow the rest of the tutorial in order to get the domain working. Then you can continue hosting the site here.