Updating your WordPress URL from yoursite.000webhostapp.com to a custom domain like yoursite.com


When you park or point a domain or purchase a premium domain from Hostinger you’ll probably want to use that instead of 000webhostapp appearing on your site.

Only a few easy steps are needed for your site to display https://yoursite.com when loading instead of the old https;//yoursite.000webhostapp.com


Head over to your WP-ADMIN page and log in :slight_smile:

Once you’ve logged in head to SETTINGS > GENERAL bottom left of the list

You’ll see this:

You’ll need to empty it out firstly

Enter in your parked domain (please ENSURE this is parked correctly BEFORE changing)

Now simply save, and log out of WP-ADMIN.

Access your site using your new URL http://yoursite.com and it SHOULD load fine.



If you see to have a few broken links - permalinks might need updating - head to SETTINGS then PERMALINKS


Then SAVE.

Log out and try your site again.

Custom domain is being redirected to hosting domain. Need solution
Wordpress domain settings
Too many redirects TTV
Need help asap on my new webiste
My domain not working - redirects to old domain

There is another method available if you feel you want to edit your URL directly via the database.